Common Data Service, dataflow, Power Platform

Dataflow for Power Apps: “section Section1;…” error on create

This error for me occured when I was copying scripts and using blank queries.

This is not my image, not my database, so don’t try to access it, please 😀 I found it in Internet to illustrate the point.

section Section1; error

This message is a little bit a lot not helping. If you deploy something to PROD at night it is also very stressful. So what do we do?

We start here: https://docs.microsoft.com/en-us/azure/azure-portal/capture-browser-trace

This is to try to capture a little bit more info before we ended up contacting Microsoft support.

I was supper lucky, if it’s the right thing to say in the current situation.

After my error appeared again, I click on Developer Tools in my browser (Ctrl+Shift+I) and did a little bit of recording on the Network tab. Pressed Create button again. Got the real error.

Mine was like this:

{“error”:{“code”:101200,”message”:”Invalid Cdm model Format”,”details”:”Name of ‘Attribute’ cannot contain leading or trailing blank spaces or consist only of whitespace.”}}

I don’t know where did that white space come from. But we founded it and fixed it at the end.

Happy days!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s